Slow plugin loading (previously worked fine )

O.K. It seems that reaper is now also affected , slow plugin loading , taskmanager cpu increase with certain plugs (just tweaking onboard gui controls ) etc…
Otoh , loomer architect is not affected yet , weird , weird …weird

Maybe related: does it go away, if you physically disconnect the lan cable / disable the wifi device in the device manager?

2 days ago DSL wasn’t working anymore, but it looked for the router as working, so also each connected computer had the status “internet working”. Then even the os Startup, and Apps Startup Dramatically increased. It seems that a ton of information is exchanged these days at startup, also a lot of plugins do that. if you block everything in a firewall, it seems to look like “internet not working”, so Startup times are normal again.

So installing a proper outgoing connections firewall and block everything could be a test here, too.

I really don’t know , it just happens out of nowhere
Disconnected to the web doesn’t make any difference , firewall enabled-disabled either .
Right now , at least one version of Renoise is behaving o.k. again , the other one and Reaper don’t
In reaper it is just the slow gui loading and cpu increase while tweaking vst,s , in renoise it’s all that + stuttery screen when recording ( play position set to scroll ) .
I did some direct x diagnostics and Taktik didn’t find anything weird in the direct x log
It def.has something to do with how certain plugs are drawing their graphics + gui interaction (mouse down etcc) , but at the same time it’s behaving all right in one Renoise version while odd in another …
It’s so frustrating , if only I knew which win 10 process is causing this

Another longshot: turn off file indexing? I have had troubles due to me having too many, several thousands, files.

These are turned off by default

I can definitely confirm that I have a similar behavior.

I’ve used Windows 10 and upgraded to Windows 11. I think this was happening to me before with Windows 10, and it’s still happening with Windows 11, on the same machine. I even created a thread with a confusing issue related to this.

Apparently, in most cases, Renoise starts fast, plugins load at normal speed, and the LUA tools run fast, as usual.

But sometimes when you start Renoise, you notice that something is wrong. It loads slower and closes slower, and it also affects the loading of plugins and also some LUA tools take about 3 or 4 times longer to load (if it used to load in 0.5 seconds, now it takes about 3.5 seconds). This also affects the overall graphical fluidity of Renoise. Control becomes slow and choppy, both in Renoise and in the window Lua tools.

Apparently it only seems to affect Renoise, but I’d say it’s an issue between Renoise and Windows, affecting both Windows 10 and Windows 11 as well. Tested on the most recent versions of Renoise, 3.3.2 and next.

It’s frustrating because I have no way of figuring out what’s causing it. It just happens sometimes.

The only thing I can say is that in my case, it affects the loading speed and also the fluidity of the graphics.

While all of this is going on, I never touch any of the Renoise settings. Simply, sometimes it goes well, and a few other times it goes wrong.

I don’t think the internet connection and its use have anything to do with it.

I use an Nvidia graphics card with up-to-date original Nvidia drivers, and an Intel processor.

At first I also thought it was a specific renoise -win issue , but now Reaper is also affected ( exact same slow plugin loading )
Renoise justt has additional issues ( laggy pattern when recording ) which Reaper obviously doesn’t have .
I remember reading somewhere that since recently win 10 had a new background process to gather data and slow down overall performance , forgot the name of the process but remember killing it once and the issue went away .
Right now the only host that is unnafected by all this is Loomer architect

And just while writing this , loaded up renoise and the issue is gone again ( holding wood ) , this time it lasted for 2-3 days

Well I just had this problem right now.
I solved it by deleting the Renoise log.txt file, after closing it, which was over 1MB. Now it occupies 11KB.

The next time I load Renoise it works fine. I don’t know if the log.txt file is related to all this, but something is wrong. When Renoise detects that the log.txt file does not exist, Renoise creates it again.

Edit: I have tried it with 2 different versions of Renoise, and in one case it has solved it and in another it hasn’t. I highly doubt it’s the log.txt log. Something is going on that causes Renoise to not work fine with Windows. In the windows task manager I don’t see anything strange.

I’ve exact the same issue with sluggish lua tools. It can easily spotted with UI heavy lua tools like our piano roll one’s. I thought, its something bad with my lua code. I found a font error in the log, which i’ve fixed. But i don’t know, if this was the cause. Everything works currently fine and fast. Happens 1-2 times in a month on my windows 11 system.

This has nothing to do with the Lua code of any window tool. You can try to uninstall all the tools and the problem still persists. Difficult to determine the cause.

And it happened again , deleted the log file …same stuff
Can’t use Renoise longer than a week without the issue re-appearing

Does the issue continue after a restart?

Yes , it will probably go away after 2-3 days if I am lucky
I disabled windows defender , no luck
At the moment already one version of renoise and reaper show the slow behaviour , it’s just a matter of time before the other version of renoise follows .
Things I know so far

  • Two programs are affected ( renoise , reaper )
    -The issue is gui related and perhaps hid related ( keyboard input while recording )
    -Only happens with certain plugins , but in the case of renoise also the recording from pc keyboard.
    -Issue re-occurs after a week , and dissappears after a few days
    -Closing renoise also takes longer ( killing the graph engine )

Edit , I just deleted the log file from the (yet ) unafected renoise version , and the issue appeared immediately after restarting renoise

How about deleting the cached VST plugin databases and rescanning all plugins? It might be worth a shot.


The files can be found in C:\Users[the_user]\AppData\Roaming\Renoise[the_version]

At damn chicken , did all that …the issue is also present with just recording from keyboard usng plain renoise instruments and NO vst’s
Killing 'the diagnostic policy service 'from taskmanager did the job , but the process always comes back and I think it is related with the Microsoft defender antivirus Service , which can’t be killed .
I disabled it and exluded folders but no luck
Maybe taktik can clarify as to why Renoise is affected by this

Mhn good find. I’ll try this, when it happens on my system, again.

You are crazy, how did you find this out? You are right!!! DPS is the culprit. But what does DPS to slow down Renoise here?

Made a video capture on a windows 11 system:

You can workaround this issue by stopping the DPS service via admin console: net stop DPS

@taktik Maybe you can find out the reason why. Its pretty strange.

Good find! I’ll try to test it on my machine, see if I can confirm it myself.

On the internet, there are some tips about removing “C:\Windows\System32\sru\SRUDB.dat” which is related to DPS.
I stopped the service. Renamed that file and restarted the service. Issue is gone away for me:

I cant find any logs about this service in the Event Viewer. Only a Rewire Error which is triggerde by Renoise. Maybe its related:

Name der fehlerhaften Anwendung: Renoise.exe, Version:, Zeitstempel: 0x60441125
Name des fehlerhaften Moduls: ReWire Engine.dll_unloaded, Version:, Zeitstempel: 0x61eaa3c9
Ausnahmecode: 0xc0000005
Fehleroffset: 0x0000000000031f18
ID des fehlerhaften Prozesses: 0x4718
Startzeit der fehlerhaften Anwendung: 0x01d824526182fd55
Pfad der fehlerhaften Anwendung: C:\Program Files\Renoise 3.3.2\Renoise.exe
Pfad des fehlerhaften Moduls: ReWire Engine.dll
Berichtskennung: a5f77bdb-fe59-4b8b-8b8a-8b12f04dacf7
Vollständiger Name des fehlerhaften Pakets:
Anwendungs-ID, die relativ zum fehlerhaften Paket ist:

Edit: Maybe also “fixable” by disabling SRUM extension “Energy Estimation Provider”:

Edit 2: Article about this SRUDB.dat file:

Edit 3: It seems removing the SRUDB.dat file is only temporary. Maybe the Execution Stats and Application Resource Usage logging of SRUM (which is documented in the article about the dat file), which is part of the DPS triggers an issue of Renoise itself, where the application becomes slow.

Have you tried excluding the Renoise process too?

This isn’t really meant as a fix, as this is dangerous. All plugins that Renoise loads will then also not be scanned by Windows defender. But if it fixes the problem we at least know that this is related to Windows Defender.