Unexpected mod device chain clipboard behaviour


(martyfmelb) #1

Steps:

  1. Create an instrument with a sample in it
  2. Add e.g. volume modulation to it by going into Sampler -> Modulation, clicking Volume and then dragging devices from the Modulation ‘folder’ to the currently empty device chain area
  3. Right-click the device chain and in the popup menu, hit Device Chain -> Cut
  4. Go to e.g. Panning
  5. Right-click the device chain and in the popup menu, hit Device Chain -> Paste

Expected behaviour:
Device chain from volume is pasted into panning.

Actual behaviour:
Device chain from volume is pasted back into volume.

Suspected cause:
a) a mislabeled submenu (‘Device Chain’ should read ‘All Devices’ or ‘Device Chain Set’)
B) a misbehaved submenu (only the current device chain should be affected, not all of them)

Video:
http://tinypic.com/player.php?v=bi79ev%3E&s=5#.Usvlg_QW2x0


(taktik) #2

Hard to say what’s “right” or “expected” here, but the currently behavior was done on purpose. Will try to rename “Device Chain” to ‘Modulation Set’ as you proposed.

Indeed would be nice to have an option to also copy/paste all devices for a specific target (volume/panning/…) in addition to copy/pasting a single device and the whole set of modulations.

Moving this to the ideas and suggestions board. Probably someone else has an opinion or idea on that…


(KURTZ) #3

… maybe this ideawould make all this more intuitive (and fun)


(martyfmelb) #4

OK, proposed fix affects at least TWO menus – main thing to preserve is the terminology in common between the two menus (in this case, “All Device Chains”).

Old on the left, new on the right.

1am again … shiiiiiiit nigh nigh

AND