Xrns-php


(Conner_Bw) #41

Ok, i’ll let you make the changes then.

Everything I have tested works fine. Will check some more later.

Keep me posted.


(Conner_Bw) #42

Updated to 1.06, shift-reload:

http://xrns-php.sourceforge.net/


(rdewaele) #43

Hi Guys,

Anyone else noticed that XRNS songs created with Renoise 2.0 are not compatible with Xrns-php , at least the merger module seems to fail to work with renoise 2.0 songs…

Any ideas ? Anyone… Help… I’m stuck here…

Feedback would be highly appreciated !

thanks


(rdewaele) #44

Well… that’s the problem… I’m no programmer…
Too bad. I really am a frequent user of the scripts, escpecially the merger script , which I use to combine several trax for live purposes…

Any volunteers / programmers ? :)

Maybe another question for the Renoise Developpers : An option to save renoise 2.0 trax as renoise 1.9 or older versions would be of great help too !

Taktik? :dribble:


(rdewaele) #45

well , in this way I would still be able to merge trax I wrote in 1.9 with trax created in 2.0

I’m desperate :)


(Conner_Bw) #46

ANGER LEVELS RISING, THEY KEEP PULLING ME BACK IN… :(

  1. Open source; when there’s a problem describe it in detail. The fact that you didn’t just wasted my time. What is the problem? No one knows. Your description was not at all helpful. HI, PROBLEM! HELP? is useless. The icing on the cake that you are unwilling to fix free software yourself. Desperate, but unwilling. This is even more frustrating.

  2. I just did some tests, merge scripts works fine. There’s a warning because of a missing schema. That’s a warning. We are in beta. The schemas aren’t finalized. That’s normal. Ideally, no one is touching XRNS-PHP until 2.0 FINAL is released. I personally won’t work on XRNS-PHP until 2.0 FINAL which is a few months away. RC candidates are not enough for me to justify doing free stuff unless it personally affects me. Others are more than encouraged to submit patches. That’s why it’s open source. That’s why it’s in a scripting language.

  3. You can’t merge 1.9 songs with 2.0 songs. You can’t merge 1.8 songs with 1.9 songs. This is not new. Save your old songs in the new way. Upgrade them to LBP mode. The merge script will work fine as far as I can tell. If it doesn’t? Actual details of problem welcome. Patches welcome.

Had you posted actual details about I could have fixed your problem without ranting. Silently, and happily, magic in the CVS for my own personal enjoyment. The fact that you didn’t, well you get this, and a bonus redirect to this thread.

For real as this time I feel I’ve covered my bases now. See you in 2009. Peace.


(rdewaele) #47

Gee. Who’s having a rotten day here?

  1. As far as I know, no one forced you to answer my question. I’m not a programmer , just a registererd renoise lover. Unwilling? I’M NOT A PROGRAMMER. I DON’T KNOW SQUAT ABOUT PHP OR XML so I can’t exactly describe what is wrong now can I ? I only noticed the trax wouldn’t merge…
    I was only trying to find out if anyone had encountered this problem as well and if anyone could give me some advice.

  2. I Didn’t expect anyone to start programming at once for me at all. THIS IS MERELY A QUESTION TO OTHER USERS. I was assuming one of the purposes of a “discussion board” or “forum” is to exchange tips & tricks with others. After this I might have to reconsider about ever posting a question again.
    Lately it seems a lot of boards and forums are diseased.

  3. I DO highly appreciate free software and open source projects. You might also see my question as an opportunity for others to look into the problem and maybe even anticipate on the new renoise 2.0 track XML structure, or are you - Mister Conner_Bw - the one and only emperor of open-source? You reply suggests something in that direction.

quote : "1) Open source; when there’s a problem describe it in detail. The fact that you didn’t just wasted my time. "

  1. Thanks for your reply and assistance. And for your precious time.

(Transcender) #48

It’s probably just Conner’s default mode of communication, talking to people by adding a slight edge of anger. Why he does this I don’t really know. But since that behaviour is constantly reinforced by all these postmodern-subjectivist-nihilist speedcore hippies who crowd this board, we’ll just have to live with that.


(Conner_Bw) #49

Your reply still has not explained your problem.

Can you please, in detail, post what isn’t working? A long boring explanation of what isn’t working? And compare it to my answers? Someone will gladly look at it if it isn’t an ambiguous stab in the dark. If you are using XRNS-SF on Windows click SHOW CONSOLE and go from there.

Yes, I agree 100% I’d be more than thrilled if others would look at it. I encourage others to look at it. Improve the project. Take over the project. Do whatever they want!

The beauty of open source is that we don’t have to get along to get things done.

The reality, at least in Renoise, is there are a lot of beggars, a lot of talkers, not a lot of contributors. Even when they have more than enough incentive to at least try…

I hope it works out for you, regardless of my attitude. Good luck.


(choice) #50

i swear i posted in this thread.

i had no issues with merge a week or so ago with 2.0. and it was the first time i used the xrns-php stuff.
i used a bunch of the scripts too. and,

i was/am still thoroughly imprrressed.

i don’t think there is any other audio software that isn’t already based on user-coding that can do this.


(Conner_Bw) #51

Long story short long (VOKUHILA?) I started a new job and am using SVN more than CVS these days.

Basically, I’m 10 years behind? So, while everyone is jumping on the GIT train i’m moving to SVN in my day to day activities.

I’d like to migrate the XRNS-PHP project from CVS to SVN.

If you’re like me (a stuborn CVS user) here’s some quick reading to understand the fundamental differences between CVS and SVN:

What this entails?

  • Migration from CVS to SVN (I can do this, I recently did it for Sux0r and have the process locked down)
  • Changes to XRNS-SF to download from SVN instead of CVS (Can’t someone else do it?)
  • Developers commit to SVN instead of CVS (Everybody do it)

Any objections?


(danoise) #52

(Connor explained how to use CVS for me, a first time user, a year ago)


(Conner_Bw) #53

I went ahead and migrated all the scripts from CVS to SVN.

By the end of the weekend I hope to repackage XRNS-SF to reflect these changes. I will also package all the latest changes to XRNS-SCRIPTS. Both will be named 1.07

I think I will include the scripts in the frontend, and remove the .cmd script altogether. I will update the docs to show how one can checkout SVN trunk, in case someone wants the latest versions.

Suggestions?


(Beatslaughter) #54

An update of php.exe and php5ts.dll taken from the current PHP distribution might be a good idea. If you remove the CVS support, you can also delete the cvs.exe in the tools folder. Maybe there is something similar for SVN… a little commandline app, which can be used in a new .cmd file?


(Conner_Bw) #55

1.07 has been released.

http://xrns-php.sourceforge.net/
https://sourceforge.net/projects/xrns-php/

Good times.


(s-n-s) #56

these tools rock

i have just recently started using Rigen to make ALOT of breaks samples into renoise instruments

its soo much fun

thank you to the people who made these tools available


(Conner_Bw) #57

XRNS-PHP and XRNS-SF 1.08 have been released.

Changes:
Fixed the XRNS2MIDI and XRNS_MERGE scripts to work with Renoise 2.5, unmaintained scripts are now in a separate “deprecated” directory, minor optimizations and bug fixes.

Shift-reload, grab it here:
http://xrns-php.sourceforge.net/


(Conner_Bw) #58

I’ve upgraded the PHP scripts to work with Renoise 2.8.

The changes are in SVN:

It’s going to take me a while to repackage the XRNS Script Frontend since I don’t work on Windows. I’ll be looking into it later this week and will post again with a release when that happens.


(Beatslaughter) #59

Here is an updated package to get the Windows crowd started. File contains the latest scripts by Conner_Bw with a modified “xrns_ogg.php” (see Changelog).

Download

Version 1.09 (03/27/2012)

Changed: Updated XRNS-PHP scripts.
Changed: Updated included PHP version to 5.4.
Changed: Replaced CVS utility with SlikSVN.
Changed: Updated included oggenc tool version to 2.87.
Changed: Updated xrns_ogg.php to use oggenc2 instead of oggenc.
Added: Licenses folder for all included utilities.
Added: Redist folder includes Microsoft Visual C++ 2008 Redistributable Packages needed for PHP 5.4 and oggenc2.


(Drop Shadow) #60

Thanks a lot. Very useful.