New Tool (2.8): scl to xrni

This lets you load scala (scl) files and apply them to xrni instruments. Download the tool here: http://www.renoise.c…ols/scl-to-xrni

To use this you need to make sure the following setting is made in the sample keyzones window:
3862 Keyzone Setting.png

And also this setting in the sample editor window after the tool has completed:
3863 Sample Editor Setting.png

You can’t set these via scripting so they need to be done manually. The tool generates 120 slices (one for every note) so may take a while to complete, just be patient it will get there in the end.

Get over 4000 .scl tuning files here: http://www.huygens-f…docs/scales.zip

Update 1.1:

  • Fixed file loader, now works properly in Windows
  • Cancelling file loader now halts script
  • Performance improvements, works much faster
  • Progress is shown in Renoise status bar

Update 1.2:

  • Appends scl filename to Instrument name
  • Bug fixes

Update 1.3:

  • Adds dblue’s updated scl loader script

Update 1.4:
Improved tuning accuracy

Update 1.5:
Detects and preserves sample basenote
Adds option to preserve/apply initial loop start and end points

Big thanks and credit to dblue for his excellent scala loading script (http://forum.renoise…scl-tuning-file), this tool would not have been possible without it. Also thanks to Djeroek for being persistant about this and microtuning in general

Feedback and suggestions are always welcome.
Cheers

Awesome! :drummer:

Trying to load my .scl files at first the loading window didn’t recognize them, screen comes up blank, until I change the dropdown from scl to . and select my SCL files manually. Dunno if these are different kinds of formats, but it works fine :) .

Probably set the extension to "scl"rather than “*.scl” in Lua.

The script is set to look for the scl extension and I’ve been testing it with the archive found here: http://www.huygens-f…docs/scales.zip

On a Mac it works fine but I don’t have a Windows setup to test it on. Could you try changing the “scl” in line 197 to either “.scl” or “*.scl” and let me know which, if any work?

No windows is very strict with wildcards.
This is the only correct method:
scl_filename = renoise.app():prompt_for_filename_to_read({"*.scl"}, “Select Scala File”)

.scl doesn’t work, also canceling the load window still ends up processing & slicing the sample, defaulting to standard, normal scale. Maybe it shouldn’t do anything?

*.scl does work! Thanks :)

future feature request: append or prepend tuning file-name next to instrument name in instrument list (between brackets).

Cheers!

Thanks, I have updated the tool with this in, so should work properly in Windows now.

I’ve updated the OP to v.1.1 which now includes the above update and also some performance improvements. Trying out further .scl files after you have done it once is now much faster, I’ve also used the process slicer to get rid of that annoying “Script is working slowly” dialog that pops up.

Good idea, I’ll look into how to do this.

Cheers

so good B)

got this bug notice after trying the .scl file ‘jemblung1’

Thanks, I get the same bug with mystic as well. I’ll look into it.

Also have you tried key mapping the tool? When I run it from a key assign it crashes Renoise as soon as I select a file. Works ok when run from the menu though, I’m not sure if that is a bug in Renoise or my system.

Nope, not yet, running out of keyboard shortcuts :) . It should never crash renoise though, best post the log details to the devs.

Trying a keymap here on windows vista assigned to ctrl+enter, working fine without crashing, maybe a mac thing?

Ok thanks, maybe it is a mac thing, anyway bug reported, if any mac users use this let me know if you get the same crash.

Also I tried loading jemblung 1 & 2 and they work fine for me, was it definitely those that caused the error?

yes, zipped 1 here, check attachment:

Attachment 3866 not found.

I can reproduce the error with that one. The bug seems to be somewhere in dblue’s loader script which I haven’t really delved into, I just use it to output a table of frequencies…

Do you use Scala? Do you know how your version of jemblung1 differs from the one found in the Scala Archive?

Nope, no idea how it differs or remember where I downloaded my scales.

Its probably going to take me a while to figure that one out as I will need to unpick how the scl loader works.

Anyway, I’ve uploaded v1.2 to the OP, it now appends the scl filename to the instrument :)

Cheers

Nice!

Had this bug notice trying out the latest version:

Slices were building up fine in the bottom statusbar, than the tuning settings and suddenly, bam…this notice. All the tunings seem to be calculated though, but the selected tuning name hasn’t been appended to the instrument name.

I can consistently bring up the notice with whatever tuning, the bug pops up when the tuning settings run through at the bottom statusbar in Renoise @ “Tuning Slice 120”

Argh, sorry about that, its a Windows thing, it uses \ instead of / in its file paths. I’m a bit stumped trying to fix this.

Can you run this command in your terminal, select a file and let me know what the output looks like?

print (renoise.app():prompt_for_filename_to_read({"*.scl"}, "Select Scala File"))  

I selected a scale and got:

Great, thanks…

Can you try inserting this code on line 267 of main.lua:

scl_filename = string.gsub(scl_filename, "\\", "/")  

Does that work?