Using Energyxt For `freezing` Renoise Tracks

I have just purchased energyXT on the strength of this as this has been one of my most wanted functionalities in renoise for a while now as I constantly max out on CPU. Just thought I`d give a quick guide on this here as this may be helpful to others.


  1. Render the track you want to freeze using renoise`s wav rendering options. i.e. muting all other tracks. Make sure All master track fx are swiched OFF.

  2. Load up XT as a VST instrument in renoise and open its GUI

  3. Right Click on the main screen of XT and choose sequencer from the menu. A sequencer icon will appear already linked to the input and output of XT.

  4. Double-Click on the sequencer icon and the sequencer screen will open.

  5. Click options menu in sequencer, choose sync mode, change to external

  6. Right-click actually in the audio track (right of the border) and choose insert sample..

  7. Choose the directory where you saved your rendered renoise file to and load it via this browser.

  8. Turn on all your tracks in renoise except the one you have frozen and switch back on your master fx. Press play in renoise and your rendered track in XT will play in sync. The best part being wherever you play from in renoise, XT will trigger the sample at the correct playing position.

:yeah: :drummer: :guitar: :w00t:

NOTE: You may now need to adjust the volume of the XT VST in instrument setting to aquire the correct playing level.

If you need to edit the sample slightly in XT as there may be a short silence at the beggining of your rendered sample here is what you can do to rectify it:

  1. Double-click the sample in XT (i.e. the audio track) and a new editor will open.

  2. Use the zoom arrows at the top of the editor to get to a comfortable magnification for prcise editing. Use the scroll bars to get to the beggining of the sample.

  3. Turn snap off by pressing the snap button.

  4. Now this is where you have to be quite precise as this is a bit different from the renoise sampler editor. Press Alt on your keyboard and left-click with the mouse exactly where you want your sample to start. This chops the wav at that point. Now click the part at the beggining of the wav that you want to discard and press delete on your keyboard.

  5. now drag the remaining sample to the left of the editor. Sometimes the snap function can be useful here to get the start position right, you just have to do this by a bit of trial and error.

  6. Test by pressing play in renoise. There is a right-click undo function in XT if it is not correct the first time or you can always add voxengo`s Audio delay VST in XTs main screen to adjust if you cut too much and find this easier.


I hope that was all clear but if you have any questions I will try and answer and edit the above steps if needed. I have also only learnt a fraction of XTs functions so far, so there may be slightly better ways of doing the above, but I will post back if I find them. Please do add more if you can to this thread.

This is all possible to try out for yourself on the XT demo, though if you save in it you will not be able to retrieve that save until you register. (disclaimer: the saving part is only from memory so please check this before you rely on it!)

EDIT: Obviously you can render more tracks to one single wav in renoise if you wish. I just explained the simplest scenario for showing the basic procedure, I`ll leave the experimentation with this to you as I am still experimenting with this myself ;)


EDIT 3:

Updated for energyXT version 1.36

Great tips!!

I could understand this operation.
Thanks very much. :yeah:

Nice tip.

You are basicly describing how to use energyXT as an ‘audio track’ player in renoise (it also support drag/drop of files btw).

Another way of freezing your track (vsti track) in XT is to do as you described by adding an sequencer. (open … - new - seqeuncer). By default you now have 2 midi tracks. Right click track 1 and (output - VST - [vsti instrument]).
Now this instrument can be tracked in renoise.
When you wanna freeze it you just hit record in XT and then hit play in renoise.
The notes will now be recorded into xt. Then hit ctrl+f to freeze the track.
After freezing the instrument will be bypassed by default so you only hear the freezed file when you play back.
By default all insert fx in XT are also freezed.

Now just think how wonderful the world could be if Renoise had native support of Audio tracks and freeze. :rolleyes:

cheers

Thanks! Great tips!

Yes, thats right to work to the purpose of saving CPU. Thought about the drag and drop and how it could help this procedure. I will change my first post to include this. Thanks.

:yeah: :w00t: This is great news! I was hoping there would be a way like this.
Thanks a lot Pysj, I will try this out and add a step by step in my first post, crediting you of course ;)

Look forward to that day! but until then XT has been for me, my VST find of the year!

Hi, thanks more interesting tips! :walkman:

I almost understood Pysj’s tips,
but there is a thing that cannot understand a little.

When I started recording, XT inserts 4 counts in the head of the track.
It can’t record notes during the 4 counts.
Cannot I start recording notes in XT as soon as I hit play in Renoise?

You can turn off or change the count-in in the Master section of XT.

Uhm! Thank you very much!!
It’s perfect.

I like the GUI of Orion V1.1.
It is more better if there is the GUI of Renoise look. :)

More good news thanks Pysj :) , saved me a bit of manual reading there.

More of aptlook GUI fan myself :) . Though both of them are far better than the default.

but how can i start recording in eXT and playing in renoise at the same time?

and somehow the freezed track sounds distorted… :unsure:

Soz fcuked up this post by editing wrong and losing the old info…

Here are some more useful tips from Pysj from this thread for using XT with renoise:

http://www.kvraudio.com/forum/viewtopic.php?t=99869

Thanks again to Pysj for these.

Also another issue I have found around using XT and renoise together is that when you make audio recordings in sync mode, it is important that you press the panic button in renoise before you press record in XT and wait for the renoise CPU meter to drop to its lowest value. This will ensure that your recording is in proper sync and little if any adjustments have to be made afterwards.

I believe this is due to an XT bug, but I have posted this on the XT forum so that if it is it should hopefully get fixed sometime.

In the previous bodged edit I erased something I said about XT not being able to record audio as a VST effect. This is not true as it can, but the panic button rule in my previous post needs to be taken account of.

This is now not necessary since the 21/10/05 beta of XT which has dealt with this issue :)

it works quite nicely, but energy is still quite buggy, press the wrong key and it drops dead, taking renoise with it.

also, is there any “scissor” in the sequencer ? so I can cut a big wav in to parts and drag them around ? Right now I am duplicating the wavs and drag the start and end around to get the part I want, but thats not really cool.

but overall it works really nice, thanx for that great hint.

Alt + rightclick will split the part/clip in eXT.

Another hint: if you are in in-track edit mode in the sequencer (press ‘E’ or double click the space below Solo/mute/rec buttons) then you move clips inside the part by leftclick hold and drag. To move the part in this mode you must leftclick on the top 5 pixels or so of the part, hold and drag. So to split the part and not the clip in this mode you will have to alt+ rightclick on the top 5 pixels of the part.

and… never seen many bugs in eXT. I have never had any crashes using it inside renoise.
Does it even crash without using any vst(i) inside eXT?

cheers

well, when I was looking for that “split” function I tried alot of shift/alt/strg-left/rightclicks and that often crashed energy. even the standalone version.

The split function is not one I often use but just trying it using Alt I can get an exception error in renoise. I have posted recently on the XT forum about a bug similar to this so will probably get back to jorgen on the XT forum about this.

In the meantime it might be worth trying the last stable version of XT:

http://www.xt-hq.com/download/

on the left of the page non-beta version, but can not promise anything.

I know XT2 is in the pipeline soon so hopefully anything related to this can be fixed with these versions.

I just tried this with the demo of energyxt.

It is really nice to be able to trigger samples midway though a track like this.

I think it is time for renoise to implement audio tracks. It is well overdue

Maybe for 1.9?