Windows 32bit and 64bit support on Linux with vst-bridge

Hi,

I wrote a new vst bridge for Linux: https://github.com/abique/vst-bridge it is free software under the MIT license, yet you need the Steinberg VST2.4 SDK to build it.

It differs to other solutions by being a 1:1 VST mapping, and so lets you automate parameters, save plugin’s settings etc… :)

From the README:

Right now I successfully used Synth1, ReFx Nexus, u-he Diva, ABL2, epicVerb, NastyDLAmkII.
I had failures with Reaktor, Oatmeals.

Feel free to share you experiences, report bugs on Github.

Enjoy! :)

oooh now this is interesting! Does it require wine? I’m using 64-bit Arch.

You need wine, I use the one available from arch :)

hate to bother you with this but how do the VOS plugins run, especially, the NastyDLA and epicReverb?
(http://varietyofsound.wordpress.com/)

I did try epicVerb and it worked, yet I recommand to change the parameters from renoise rather than the GUI as it has redraw issues (I don’t know why).
I also tried NastyDLA and it worked, but I still recommand to hide the GUI.

does 64bit bridge support 32bit plugins?
also does it save settings in projects?

Renoise LOG> ProcessPipe: Failed to create wait event : ‘RNS_PipeTrigger-5234-14’
Renoise LOG> Error Message: Internal Error: Failed to create the event communication pipe for a bridged audio plugin. Please make sure that enough disk space is available for temporary files.

not working

Yes it does.

Try without running plugins in sandbox. I’ll look into the sandbox issue.
Can you tell me which plugin you’re trying?

Thanks.

Hey, I have a problem with configuring with the “[[”'s:
./configure: 12: ./configure: [[: not found
the same on line 16,20,24,28,32
Maybe I’m overlooking something, can you help me
Thanks in advance, I’m very happy that you’re sharing this

Hey, I changed the interpreter to be /bin/bash so [[ should work now :wink:

lol it seem not any of synth are properly wrapped in midi means, so i start plugin, but sound comes only after i press button inside plugins, not midi
so there’s list of synths i tested with that problem
Elektrostudio pack
MinimougeVA
TubeOHM AntiTranspirant (also sometimes causes crash at use :()
arppe2600va
Drumatic 3
FMMF
Oddy-free
Prophanity

i know that all there synths works with dssi-vst (midi at least)

Let me have a look.

WOW, hands down. Almost everything works (what doesnt are some fonts in synth1 for example). Ive tested all bootsy plugins and then kamioooka, synth1, drumatic4, exd80. I suppose that renoise project with vsts will be portable to windows now.
The only thing that i am still not sure about is if it doesnt destroy quality of sound in some way. My memories about these plugins on windows are with better sound, but its just memories influenced by yoshimi :rolleyes:/>

Hi and thanks Akiz!
For the missing fonts, I think that you just have to install them with wine-tricks.
For the quality there is no losses, but it has a small cost in performances due to the IO overhead.
Enjoy! :slight_smile:

Ok, i’ll check it. Thanks.

Btw. I think that your way how to bridge vst is great especially for ‘renoisers’. If that plugin doesnt work great i can just render it.
Thanks to you i am fully satisfied with my linux workstation for now. Funny is that i ran away to linux because i was flooded by vst plugins and now this mania menaces again :D/>.

Ive tried square1 from Cakewalk and it also works. Moving by knobs makes some sound glitches (in other plugins too), but as we use renoise we dont use gui for automatization so it doesnt mind :rolleyes:/>.

And Elektrostudio analog synth pack works amazingly.

Issues:
SFZ+ doesnt work, so iam looking for another nice free sf2 player.
Sometimes jack shuts down but for now i can not surely say that somehow relates to your app.
(btw. maybe somebody can make gui for faster and multiple conversions it would be bomb)

So, it is common that something crashes if song is playing and you are changing parameters (can be replicated by using BootEQ from Variety of Sounds). So it is not very usable for realtime tweaking but for “static” sounddesign it works good.

I use u-he plugins, and I can tweak parameters while playing. Maybe it is a plugin issue?

Yeah, just something. Same with cpu intensity, something creates a lot of x runs something works without flaws.
I dont use FST (have some problem with dependencies on my Manjaro system) so i can not compare your bridge with it. But i would like to know if your bridge takes more or less system resources.

It does not take that much resources.

I am really interested in this, however I am having trouble installing it.
I downloaded the SDK from Steinberg, but had to copy the several .h files into a new folder inside pluginterfaces/vst2.x because the make file was looking there. Now it is looked for /sys/uio.h and I am still trying to find how to get that file (Ubuntu 12.10)