Windows: Guitar Rig 5 fails to scan and load

Getting the same error in log.txt, in this case with Guitar Rig 5:

VstPlugs: Trying to instantiate D:\VSTplugins\Guitar Rig 5.dll
VstPlugs: Instantiate FAILED (caught structured exception) !!!

Since the first time it crashed (after saving a song file, which did appear to complete correctly) it it seems to be impossible to load GR, or any xrns which uses it, crashing Renoise while loading the file. Nothing was installed or changed on the computer before this started happening, so it’s kind of a mystery to me where the problem came from all of a sudden.

When checking ‘run all plugins in sandboxes’ in the preferences, Renoise doesn’t crash ‘hard’ when it’s enabled though it just stops responding indefinitely, as opposed to the program literally disappearing from the screen with the option disabled.

The newest message I could find about this issue on the forums was from 2019, though the fix proposed there doesn’t work for me:

Solved by svenfux in post #3

I found out that I had an older version of Renoise installed (3.1 when the newest was 3.1.1). Updating to 3.1.1 fixed it for me.

Sort of expected it not to work though, as there seem to be posts going back to 2011 reporting the same problem.

I have tried loading GR in 3.1.0 (which is the version I used to create the file), 3.2.0 and 3.2.1. The same error is present in the log files of all three versions.
When looking at windows event viewer, I found this error message:

Faulting application name: Renoise.exe, version:, time stamp: 0x5dc3e43f
Faulting module name: MSVCR120.dll, version: 12.0.21005.1, time stamp: 0x524f83ff
Exception code: 0xc0000409
Fault offset: 0x0000000000074a30
Faulting process id: 0x43f0
Faulting application start time: 0x01d5c069bc80e361
Faulting application path: d:\Program Files\Renoise 3.2.1\Renoise.exe
Faulting module path: C:\WINDOWS\SYSTEM32\MSVCR120.dll
Report Id: 57e85efd-8927-4234-b1d7-91aaf68fd6ca
Faulting package full name:
Faulting package-relative application ID:

So I looked up MSVCR120.dll, and it appears to be included in Visual C++ 2013 Redistributable, though reinstalling it did not help either.

Reinstalling GR did not work, and the same goes for removing the plugin database files and then rescanning VSTs, as on rescan the process came to a standstill, and upon forcing a crash and restarting I got the error message saying GR will no longer be instantiated until the failed plugin cache file is deleted…

Not really sure what else I could try, though it would be nice if I could continue working on some things that use the plugin.

edit: forgot to mention operating system, Windows 10 64 bit. Also all used Renoise versions are 64 bit. Now going to try the last 32-bit build to see if bridging the plugin is going to work somehow.

edit 2: Didn’t work, scanning the plugins did go through without crashing but when loading a song file that utilizes GR there seems to be no progress loading, and when checking the log file, sure enough:

RemoteAudioPlugin: Instantiating ‘D:\VSTplugins\Guitar Rig 5.dll’…
RemoteAudioPlugin: Creating pipes…
RemoteAudioPlugin: Launching plugin server process…
RemoteAudioPlugin: Connecting to the server…
RemoteAudioPlugin: Creating server thread…
RemoteAudioPlugin: Creating plugin instance in the server…

Nothing happening after that log entry, Renoise still ‘loading’ but nothing is happening for a while after that, and no activity showing in the task manager either.

So somehow, somewhere this file got tagged by the system (at least that’s what seems most likely to me at this point), as it does seem to permeate throughout different Renoise versions, and I can’t really find anything regarding a common Renoise folder which contains some rules regarding dll/vst files, except of course the database files. Can’t find anything pointing in the direction of windows either though, not in any system logs or something defender, not using any additional antivirus/firewall so that also seems like a dead end. All in all pretty mysterious. And annoying :stuck_out_tongue:

Some VST plugin fails to load with "Instantiate FAILED (caught structured exception)". What does this mean? maybe this works for you aswell?