Tool For Testing: Akaizer Time Stretch And Pitch Shifter

Hi all,

Well, I’ve had a nice holiday and a break from Renoise and now I’m back I thought I’d push a new tool out for general testing.

The following is information about the Akaizer tool and version 0.9 is attached to this forum post. Please test on all platforms (Windows/Linux/Mac) to identify any errors before the tool goes live on the main tools page.


The Akaizer tool for Renoise integrates the AKAIZER freeware cyclic timestretch and pitch shift tool into the Renoise sample editor.

From the Akaizer website:

Please visit the Akaizer website for more details about the application.

The Renoise tool is a simple wrapper for Akaizer which is accessed from the Process menu of the sample editor.

Upon execution the tool will present a GUI dialog in which the user can specify all the Akaizer parameters (time stretch percentage (25% to 2000%, cycle size (20 to 2000) and pitch shift (-24 to +24 semitones).

Upon confirmation, the tool will then process the selected sample and reimport it.

This tool makes a nice compliment to the rubberband timestretch and pitch shift tool and gives a more ‘classic’ stretch sound.

Akaizer executables for Windows, Linux (32bit) and Mac are incorporated into the tool download.

I would like to express a large thank you to Ben from the Akaizer project who compiled the command line versions for all platforms for integration into this tool and for being open to the idea of Renoise integration.

Thus, if you use Akaizer in your projects to good effect please pass on any gratitude to Ben rather than myself as I have overall contributed little to this tool.

Download test version here

1 Like


had a bug first time running it:

edit tried to stretch a 44100Hz 16 Bit mono file


Is this a Vista/Win7 thing? It works fine on my XP machine.

Does Akaizer actually run? Did a command prompt appear with Akaizer inside running the conversion?

Does rubberband work?

Any other feedback from anyone else? Does this plain just not work on newer versions of Windows, how about the various Linux’s and Mac?


got the same error as jonas on win7 x64. command prompt opens up and akaizer works but after its done it shuts down with mentioned error. rubberband works fine. thanks for trying to integrate this, looking forward to it!

Can reproduce this bug in Winxp SP3:

std::logic_error: ‘trying to load sample data from a non existing file: ‘C:\DOCUME~1\tom\LOCALS~1\Temp\Renoise-2980\Renoise_TmpFile-0-8-70%_1000_0.wav’’
stack traceback:
[C]: in function ‘load_from’
main.lua:71: in function ‘process’
main.lua:128: in function ‘show_dialog’
main.lua:139: in function main.lua:138


akaizer ‘works’ in that the command prompt opens, but thats all, it won’t stretch the sound.

#! (CrunchBang) Linux 32bit (is based on Debian Stable)

Time Factor = 125

'/home/rhowaldt/.renoise/V2.7.1/Scripts/Tools/com.mxb.Akaizer.xrnx/' failed to execute in one of its menu entry functions.  
Please contact the author (Martin Bealby | mxb ( for assistance...  
std::logic_error: 'trying to load sample data from a non existing file: '/tmp/Renoise-8438/Renoise_TmpFile-0-7-125%_1000_0.wav''  
stack traceback:  
 [C]: in function 'load_from'  
 main.lua:71: in function 'process'  
 main.lua:128: in function 'show_dialog'  
 main.lua:139: in function <13></13>  

file in said directory is: Renoise_TmpFile-0-7.wav
so seems to be a filename-issue.

(same thing happens with all the other options)

great work.
if we can’t have timestretching/pitch shifting built into renoise itself yet at least we can use this.

Linux here. I don’t know where Akaizer would normally write the file, but it’s not in the same directory (/tmp) as the original. I’ll keep consolewindowin it up

EDIT. Akaizer only works if you launch it with the full path, somewhere the plugin fails this under linux. I replaced only one line where it says ```
exe = …

OK I found your Linux / probably osx bug. You’re setting execute permissions on the Akaizer executable in the last lines of your script. But the filenames are incorrect. Change ```

if os.platform() == “MACINTOSH” then
io.chmod(renoise.tool().bundle_path … “bin/mac/akaizer”, 755);
if os.platform() == “LINUX” then
io.chmod(renoise.tool().bundle_path … “bin/linux/akaizer”, 755);

into ```  
if os.platform() == "MACINTOSH" then  
 io.chmod(renoise.tool().bundle_path .. "bin/osx/Akaizer", 755);  
if os.platform() == "LINUX" then  
 io.chmod(renoise.tool().bundle_path .. "bin/linux32/Akaizer", 755);  

and I think it should work mo alrighter. In linux and osx filenames are like totally case sensitive.

I hope it is!

Before it goes on the tools page I think we should contact the guy who made Akaizer, n check if it’s ok to distribute this…


download it and check out for yourself? Or d’you mean, whether development continues?

wth, which OS? Under windows there’s no error for me but a command window, on Linux exactly the opposite.

to be clear; I’m not the developer of this tool.

^ that looks like the same kind of error i got on Linux. assume this will be the first thing fixed as it seems to be the thing people are running into everywhere.

Sorry for the huge delay in reponses, my internet connection has been under attack (for some reason) and my old hardware couldn’t cope with it so I had to upgrade part of my infrastructure.

The tool saves the sample to a temporary file name to be fed to Akaizer. This is of the format: ‘Renoise_TmpFile-0-X.wav’. This files goes into Akaizer.

After Akaizer has done its work it will write the new sample to a new file. This will be of the format: ‘Renoise_TmpFile-0-X-AAA%_BBBB_SCC.wav’. Where AAA is the timestretch percentage, BBBB is the cycle length and SCC is the sign and transpose amount (e.g. -10 or +5).

Version 0.91 (see below) will display both of these filenames to the Scripting Terminal. Please run the tool with the Scripting Terminal open and see if the expected filenames exist (I have also deleted the code to erase the files after processing).

Yup, well spotted! This has also been fixed in 0.91.

Regarding all the errors, the only thing I can think of are:

The Windows version of Akaizer includes its libraries in the Scripting Tool folder. On Vista and Windows 7 I understand there are some additional security provisions and I do not know enough about them to understand if they interfere.

What would be extremely helpful is if people who try this tool post responces in the following format (to narrow down the possible error vectors):

Works? / Operating System / CPU & Architecture

e.g. for me it would be:

Yes / XP + SP3 / Pentium 4 (32bit)

Download version 0.91 here


0.91 = Nope / windows vista premium / core 2 duo

These two are with the old version and some tinkering of myself:
Yes / WinXP (32) / Core2Duo
Yes / Zenwalk Linux / Core2Duo
I’ll test the new one out right now. Thanks mxb!

And maybe useful as well: if you get the filename error, like everyone else, look in the folder where the file should be, and compare the filenames.
so Check / OS / CPU / FN expected / FN found
people can also check for their OS how well Akaizer works from command-line, this is great to know for debugging. :D

0.9 = Yes / Windows XP SP3 /Core 2 Duo
Loved the original app but this is just perfect!
Niceone :)

Awesome! I love Akaizer so this is a great way to speed up my workflow.

I get the same error message on the mac