New Tool (3.0): dBatchProcess

Since batch processing sample data with lua is pretty slow, i wrote a new tool, mainly for trimming silence from recorded samples and normalizing.

The “SoX: Normalize (Relative)” preset normalizes all samples relative to the loudest sample in the instrument.

I added a couple more presets, see for full documentation, some of the examples didn’t really work for me tho.

You can use other executables than SoX too ofc, @in and @out represent the oringal/processed files, if there is no output file it will load the @in file back into the instrument.

Should work on Windows and Linux (Mac too?) … make sure the PATH ends with a slash!


re.dread.dBatchProcess.xrnx (6.3 KB)

1 Like

Great, i was planning to programming a sox tool , too. But yours is great for basic stuff. Are you planning to add a preset editor?

Thx. No preset editor planned for now. Was thinking about it, but it does the job for me, and putting more effort into the presets, you pretty much end up rewriting the CDP tool. I think it might make more sense to add other executables and batch processing to CDP in the long run.

hey, I find your tool really useful but I can’t seem to get it working

every time I try to process a sample I’m getting this “WARNING: No output file produced[…]”

I’m using linux (arch, x64), but know nothing about lua…

If you could give me some indications on how to debug this I would appreciate it

I’m filling the gui sections like this


and if I run Renoise in a terminal, if I click “Process sample!” I get this

sh: /bin/sox /tmp/Renoise-0-25612/Renoise_TmpFile-0-3.wav /tmp/Renoise-0-25612/Renoise_TmpFile-0-4.wav pad 0 3 reverb 2>&1 : No such file or directory

thanks in advance!


Just tried it and you’re right, doesn’t work under linux.

I uploaded a new version that works for me, are you sure you have the right PATH though? … sox is in /usr/bin/ for me, not /bin/.

Let me know if it works now, cheers.

it works now!!

in arch linux /bin is a symlink to /usr/bin

thanks a lot re.dread :walkman:awesome tool!

Modified version here, if you want to review the changes.

Is there any way to use this tool without it breaking loop points?

I was looking for a tool to batch normalize the samples in a multi-sample instrument and this tool does the job perfectly, thanks! :yeah:

Gui/functionality reminds me of Johann’s old ‘run cmd on selection’ tool which seems m.i.a ( ), like the CDP tool you can add sliders, set ranges for parameters that accept it.

Are there any plans of implementing similar functionality in the batch tool? Would be great, though seeing this is an old thread I’m necro’ing… probably not…

Last time I checked, the documentation of Sox doesn’t have a good overview for all the options and correct syntax for all the processes, right? + when supplying incorrect arguments/values, it doesn’t return any info on what’s wrong, opposed to the CDP programs. For a boring vacation, might look into hacking the CDP tool or Johann’s commandline thing if presets can be easily produced.

I can’t get it to work, maybe the automatic upgrade did not work properly? It looks like it processes something and i get no error message on the ‘Normalize’, but there are no files written in the output folder and the the actual Renoise instrument has not been changed. Am i doing something wrong perhaps?

I like dBatchProcess: a tool that does exactly what I’m after, really quickly, and with great results :slight_smile:

Re. automatic upgrade: I just installed in Renoise 3.1 on Mac, and had no problems.

1 Like

@ReDread link seems to have been lost in the forum migration - any chance of a re-upload? Sounds like a very nifty tool.

1 Like

re.dread.dBatchProcess.xrnx (6.3 KB)
Lill late :slight_smile: , but hopefully this works, rarred it from my tools folder and changed the extension back to xrnx.

Great tool, which functionality can be extended through inputting moar commandline goodness as there are plenty of more effects to be found here; SoX

If I can find time I’d love to remix @afta8 CDP tool, adding SOX presets instead or additionally.


I can’t get this to install in Renoise. Is there a way to manually install this?

Have you downloaded and installed sox to your computer first? Then when the tool is also installed in Renoise, you need to direct the tool to the directory where sox can be found. Do you get some kind of error notice in Renoise?

I can’t get it to install like a typical Renoise tool. I double click it to initiate it and it just opens Renoise and populates itself here:

I cannot drag and drop the file onto Renoise to install either. Not sure if I’m missing something here! I do have SoX installed at least. Thanks for your help @Jonas in trying to get me sorted!!

Ooh that’s weird, I might have just messed up rarring it? Can you check if right clicking a sample in the sample list has an entry for the tool;

It’s an oldie so you might need to change the manifest file in the scripting terminal to the latest api version? But I’m running out of time here, have to run! Good luck :slight_smile:

Nope, no options. I don’t even think the tool is installing with the way it is rar’d. Ah oh well

When I have time, I’ll upload the unrarred tool content, perhaps someone more able can fix it :smile: .

Why not zip (instead of rar) the files into a xrnx(?)

re.dread.dBatchProcess.xrnx (6.4 KB)